Incident notification

Incident Report for Stacuity

Resolved

This incident has been resolved.
Posted Jul 15, 2026 - 07:40 UTC

Investigating

Dear Customer,

Stacuity is currently investigating an intermittent service issue that was first identified at approximately {IncidentTime} and is affecting a number of customers.

The cause is currently being investigated, and efforts are underway to restore normal service as quickly as possible.

We apologise for any inconvenience caused and will provide a further update shortly.

Best regards,

Stacuity Support
support@stacuity.com
www.stacuity.com
Posted Jul 14, 2026 - 12:38 UTC
This incident affected: Stacuity Sandbox.