Incident notification

Incident Report for Stacuity

Resolved

Stacuity is pleased to confirm that the service issue first identified at approximately {IncidentTime} has now been resolved.

Services are operating normally, and monitoring has confirmed that the issue has been successfully addressed.

We apologise for any inconvenience caused and thank you for your patience and understanding while we worked to restore service.

Stacuity Support
Posted Jul 15, 2026 - 07:43 UTC

Investigating

Stacuity is currently investigating an intermittent service issue that was first identified at approximately {IncidentTime} and is affecting a number of customers.

The cause is currently being investigated, and efforts are underway to restore normal service as quickly as possible.

We apologise for any inconvenience caused and will provide a further update shortly.

Stacuity Support
Posted Jul 15, 2026 - 07:42 UTC
This incident affected: stacuity Web Site.